Scheduled for March 12, 2025 at 10:00 PM – March 13, 2025 at 2:00 AM
Affects
Remote Desktops
Under maintenance from 10:00 PM to 2:00 AM
Completed
March 13, 2025 at 2:00 AMCompleted
March 13, 2025 at 2:00 AMMaintenance has completed successfully
In progress
March 12, 2025 at 10:00 PMIn progress
March 12, 2025 at 10:00 PMMaintenance is now in progress
Planned
March 12, 2025 at 10:00 PMPlanned
March 12, 2025 at 10:00 PMOut network provider will be performing an upgrade on aspects of their core network. We are not expecting any impact but have been informed that service could be affected during this time.