Scheduled for March 27, 2025 at 9:00 PM – 10:58 PM
Affects
Remote Desktops
Under maintenance from 9:00 PM to 10:58 PM
Completed
March 27, 2025 at 10:58 PMCompleted
March 27, 2025 at 10:58 PMMaintenance is now complete.
Update
March 27, 2025 at 10:54 PMIn progress
March 27, 2025 at 10:54 PMThis maintenance is ongoing; Citrix sessions are unaffected so work can be continued as normal.
In progress
March 27, 2025 at 9:00 PMIn progress
March 27, 2025 at 9:00 PMMaintenance is now in progress
Planned
March 27, 2025 at 9:00 PMPlanned
March 27, 2025 at 9:00 PMWe are planning to carry out maintenance on our Citrix environment during this time.
Please be aware that no downtime is expected, but some disruption may be experienced during this window.