Wrigleys - Global AWS outage – Incident details

All systems operational

Global AWS outage

Resolved
Degraded performance
Started 6 days agoLasted 1 day

Affected

Email

Degraded performance from 7:30 AM to 9:55 AM, Operational from 9:55 AM to 7:58 AM

Video Conferencing

Degraded performance from 7:30 AM to 12:49 PM, Operational from 12:49 PM to 7:58 AM

Updates
  • Resolved
    Resolved

    This incident has been reported as resolved by AWS.

  • Update
    Update

    All services are now back to normal. We will continue to monitor for any issues that remain.

  • Update
    Update

    Mimecast is now online an external emails are now being delivered and received.

  • Monitoring
    Monitoring

    AWS has implemented a fix and are are reporting that they are seeing significant signs of recovery. Most requests should now be succeeding. We will continue to monitor this and provide additional information.

  • Identified
    Identified

    Since 8am AWS has reported an incident causing all services that rely on it to have issues so far we have seen it affect emails from external addresses, scanning, practical law company and zoom this will be updated if more are discovered.