Wrigleys - Citrix freezing intermittently – Incident details

Remote Desktops & Apps experiencing degraded performance

Citrix freezing intermittently

Monitoring
Degraded performance
Started about 10 hours ago

Affected

Remote Desktops & Apps

Degraded performance from 10:37 AM to 12:00 AM

Updates
  • Monitoring
    Monitoring

    We implemented a fix and are currently monitoring the result. If you continue to experience issues with Citrix, please contact the Service Desk.

  • Investigating
    Investigating

    We are currently aware of and investigating the issue with Citrix freezing.