Wrigleys - Outlook, Word, and Team Issues – Incident details

All systems operational

Outlook, Word, and Team Issues

Resolved
Degraded performance
Started 4 months agoLasted about 21 hours

Affected

Remote Desktops

Degraded performance from 12:38 PM to 9:27 AM

Email

Degraded performance from 12:38 PM to 9:27 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We're receiving multiple reports of Outlook, Word, and Teams hanging and becoming unresponsive.

    We are currently investigating this incident.

    In the meantime, please sign out of Citrix, wait a few minutes, and then sign back in as this appears to be resolving it for most colleagues.