Scheduled for October 15, 2025 at 8:00 PM – 8:58 PM
Affects
Document Management
Under maintenance from 8:00 PM to 8:58 PM
Completed
October 15, 2025 at 8:58 PMCompleted
October 15, 2025 at 8:58 PMMaintenance has completed successfully.
In progress
October 15, 2025 at 8:00 PMIn progress
October 15, 2025 at 8:00 PMMaintenance is now in progress
Planned
October 15, 2025 at 8:00 PMPlanned
October 15, 2025 at 8:00 PMWe are planning scheduled maintenance during this time. For the duration, access to the Z and P drives (as well as related components such as the W menu) will be unavailable.