Bighand is still available to use through Citrix. Please log a ticket with the service desk and we will get this set up.
Posted Jan 07, 2025 - 11:58 GMT
Update
We are continuing to investigate this issue.
Posted Jan 07, 2025 - 11:56 GMT
Update
Due to the severity of this incident, we have begun collaborating with a third-party to aid in diagnosing and resolving the root cause.
Posted Jan 03, 2025 - 17:32 GMT
Update
We are continuing to work with Bighand on this issue
Posted Jan 02, 2025 - 13:07 GMT
Investigating
We are receiving reports that users are being asked to log in to Bighand on their iPhones but receiving the message that their username or password is incorrect. We will investigate and provide an update once we have more information.